Hystrix and OSGI bundle


Keywords:osgi 


Question: 

I have used org.apache.servicemix.bundles.hystrix dependency to bundle Hystrix as OSGI bundle. However, I'm facing this issue:

org.osgi.framework.BundleException: Could not resolve module: [828]
  Unresolved requirement: Import-Package: com.netflix.hystrix; version="[1.5.0,2.0.0)"

Can someone help me on this?

Thanks!


1 Answer: 

The error tells you that the bundle you try to install and resolve requires a certain package and that there is no bundle that offers this package.

So in you case the package com.netflix.hystrix is missing. This means that you either do not have the hystrix bundle installed or you installed a version that does not match the version range [1.5.0,2.0.0).