python - Error while trying to install packages from conda using graphlab create launcher


Keywords:python 


Question: 

I keep getting the following error while trying to install

here was a problem updating the conda package.  Restart GraphLab Create Launcher.

Unable to update conda:
Using Anaconda Cloud api site https://api.anaconda.org
Fetching package metadata: ..
Solving package specifications: .
Error:  Packages/dependencies missing in current osx-64 channels: 
  - conda 4.0.8*
  - conda -> python 2.7* -> openssl 1.0.2d
  - conda -> conda-env -> python 2.7* -> openssl 1.0.2d
  - conda -> requests -> python 2.7* -> openssl 1.0.2d
  - conda -> pyyaml -> python 2.7* -> openssl 1.0.2d
  - conda -> pycosat -> python 2.7* -> openssl 1.0.2d
  - python 2.7* -> openssl 1.0.2d
  - pycosat (target=pycosat-0.6.1-py27_0.tar.bz2) -> python 2.7* -> openssl 1.0.2d
  - pyyaml (target=pyyaml-3.11-py27_1.tar.bz2) -> python 2.7* -> openssl 1.0.2d
  - conda-env (target=conda-env-2.4.5-py27_0.tar.bz2) -> python 2.7* -> openssl 1.0.2d
  - requests (target=requests-2.9.1-py27_0.tar.bz2) -> python 2.7* -> openssl 1.0.2d

You can search for this package on anaconda.org with

    anaconda search -t conda openssl 1.0.2d

 (and similarly for the other packages)



Process completed with exit code -1

I looked on stackoverflow threads that looked similar and github threads but nothing has helped.


1 Answer: 

This helped me:

conda install -c anaconda openssl